Schülerdaten und Zeugnisse einzelner Klassen zwischen Schulbüro und Privatrechnern der Klassenlehrer austauschen


Bei der Schullizenz SL+ dürfen alle Lehrkräfte der Schule das Programm zum Zeugnisschreiben auch auf ihren privaten Rechnern installieren.

Ein unkomplizierter Datenaustausch zwischen Schulbüro und Privatrechnern ist über den Menüpunkt

"Schule>Austausch>Komplette Zeugnisse" möglich (Aktentaschensymbol).

(SZ5+SZ6: Extras>Datenaustausch>innerhalb der Schule )

 

Neue Datenaustauschfunktion ab RGS Schulzeugnis 7.2

Ab Programmversion 7.2 gibt es eine neue Datenaustauschfunktion, mit der sich augewählte Daten (Schülerdaten, Zeugnisse, Einzelnoten, Textbausteine, Formulare..) in einer einzigen "Datenaustauschdatei" weitergeben lassen.

Anleitung:

 

Alte Datenaustauschfunktion

Komplette Zeugnisse (inkl. Formular) einer Klasse austauschen

Über Austausch>Zeugnisdatei speichern lassen sich die kompletten Zeugnisse einer ausgewählten Klasse in eine Zeugnisdatei (Dateiendung *.sz5 | *.sz6 | *.szx) auf USB-Stick speichern und an andere Rechner mitnehmen.

Über Zeugnisdatei einlesen können Sie dort die Zeugnisse einer solchen Zeugnisdatei in die eigene Datenbank einlesen.


Wichtig:

  • Bevor die Austauschfunktion genutzt werden kann, muss vorher auf allen Rechnern das Progamm installiert und über Datei>Schule auswählen>Neu eine eigene Schuldatenbank angelegt sein.
  • Die Zeugnisdateien enthalten nur Zeugnisse, wenn diese vorher über "Datei>Neue Zeugnisse anlegen" angelegt wurden. Achten Sie beim Anlegen und vor dem Speichern darauf, dass das richtige Halbjahr und die richtige Klasse eingestellt ist.
  • Wenn Sie nur die Schülerstammdaten ohne Zeugnissformulare austauschen möchten, verwenden Sie die Funktion "Schülerstammdaten speichern/einlesen" im Bereich "Andere Daten" (s.u.)
  • Wenn Sie Noten oder Textbeurteilungen einzelner Fächer mit den Fachlehrern austauschen möchten, verwenden Sie die Austauschfunktionen im Bereich "Einzelfächer".

 

Verwenden Sie zum Austauschen einzelner Klassen niemals die Sicherungsdateien (Dateiendung *.rgz oder *.zip), die sich über die Funktion Datei>Datensicherung>Sichern erstellen lassen. Diese sind zur Sicherung der eigenen Datenbank auf dem eigenen Rechner gedacht. Über Datei>Datensicherung>Zurückholen können Sie daraus auf dem eigenen Rechner immer genau den Zustand zum Zeitpunkt der Sicherung wiederherstellen aber keine Klassen zusammenfügen.

Die Zeugnisdateien (*.sz5, *.sz6, *.szx) lassen sich ausschließlich über die Funktion "Zeugnisdatei einlesen" wieder in das Programm einlesen. Ein anderes Öffnen (z.B. durch Anklicken der Datei) oder eine Bearbeitung mit anderen Programmen ist nicht möglich.

Tipp:

Das Anlegen der Zeugnisse für das aktuelle Halbjahr kann bereits für alle Klassen auf dem Schulrechner erfolgen (Zeugnis>Neue Zeugnisse anlegen). Wenn Sie anschließend über die Austauschfunktion die Zeugnisdateien an die Klassenlehrer weitergeben, sind in diesen Zeugnisdateien bereits die vorbereiteten leeren Zeugnisse (inkl. richtigem Formular, Zeugniskopf und Ausgabedatum) fertig enthalten. Die Lehrkräfte brauchen brauchen die Zeugnisse auf den Privatrechnern nur noch einlesen und ausfüllen.

 

Nach Fertigstellung der Zeugnisse, können diese auf gleiche Weise zum Drucken und Archivieren zurück ins Schulbüro befördert werden. (Privatrechner: Zeugnisdatei speichern ---> im Büro: Zeugnisdatei einlesen)

 

Komplette Zeugnisse (inkl. Formular) einzelner Schüler austauschen

Ab Programmversion 5.2.10 können Sie im Hauptfenster beliebige einzelne Schüler durch Ankreuzen in der Spalte [M] markieren. Bei Erstellen einer Zeugnisdatei können Sie die zusätzliche Klasse <M> auswählen, die dann nur genau die Zeugnisse der markierten Schüler enthält.

 

Nur Schülerstammdaten austauschen

Die Zeugnisdateien (*.sz6, *.szx) dienen zum Austausch der kompletten Zeugnisse und enthalten die kompletten Zeugnisformulare. Wenn Sie nur die Schülerstammdaten (Name, Vorname, Geburtsdatum...) weitergeben möchten, finden Sie eine Möglichkeit im Bereich "Andere Daten".

Über "Schülerstammdaten speichern" können Sie die Schülerstammdaten in eine Datendatei auf USB-Stick speichern und diese auf anderen Rechnern über "Stammdaten einlesen" in das dortige Programm einlesen.

Die Zeugnisformulare für das aktuelle Halbjahr müssen Sie in diesem Fall anschließend selbst anlegen. (Zeugnis>Neue Zeugnisse anlegen)

Datenaustausch zwischen Fachlehrern und Klassenlehrer

Wenn die Fachlehrer ihre Noten oder Textbeurteilungen selbst schreiben möchten, können sie dieses am einfachsten mit dem kleinen Zusatzprogramm "RGS Schulzeugnis Fachlehrer" durchführen. Sie erstellen damit eine Notendatei (Dateiendung *.xml), die nur die reinen Noten oder Texte einzelner Fächer enthält und in RGS Schulzeugnis 6 und 7 über "Austausch>Einzelfächer>Notendatei einlesen" ganz einfach in die Zeugnisse übernommen werden kann.

 

Zeugnisse auf anderem Rechner drucken (RGS Schulzeugnis 6/7)

Wenn Sie die Zeugnisse nur zum Ausdrucken an einen anderen Rechner mitnehmen möchten, können Sie die im Programm eingebaute PDF-Funktion verwenden. Über "Drucken>PDF" können Sie die fertigen Zeugnisse einer Klasse anstelle zu Drucken als PDF-Datei speichen. Diese lässt sich dann ganz einfach auf USB-Stick mitnehmen und an anderen Rechnern ausdrucken ohne dass dort das Zeugnisprogramm installiert sein muss.

 

zusätzliche Hinweise: